do
/catch
block so it's clear which code is throwing...
Fixes #2200
Adds a "Lock Screen Scrubber" setting to the general player to disable (or enable) scrubbing from the lock screen.
| 📘 Part of: # | <!-- project issue number, if applicable --> |:---:|
Fixes an issue reported by users where they were logged out when they came back to the app. From the logs, we were logging users out during the background refresh task. I believe we should always avoid logging users out du...
Merging release/7.78.1
into release/7.79
.
Via intermediate branch merge/release-7.78.1-into-release-7.79
, to help fix conflicts if any:
release/7.78.1 ----o-- - - -
\
merge/release-7.78.1-into-release-7.79 ...
Fixes an issue with Instagram sharing where the image is cropped, cutting off the branding image at the bottom.
This changes the aspect ratio of the shared image to 9:16 for ALL sharing destinations.
https://github.com/user-attachments/assets/f1d22ca8-dd98-4a28-88dc-af95c9f82c34
Just a small quality of life improvement to add a search bar for filtering beta feature flags.
Our Mini Player padding in SwiftUI lists could be safe area insets instead so that the list can be seen behind the player like in UIKit.
All of the uses I saw were inside of lists where we were applying padding instead of safe area insets
Merging release/7.78
into trunk
.
Via intermediate branch merge/release-7.78-into-trunk
, to help fix conflicts if any:
release/7.78 ----o-- - - -
\
merge/release-7.78-into-trunk `---.
...
Adds sorting options to Downloads including a new file size sort.
![Simulator Screenshot - iPhone 16 - 2024-12-04 at 11 39 31](htt... |
Adds a workflow file for build and testing the Swift package.
Day 2's solution with thoughts on today's solution in the Readme.
Day 3's solutions
Day 4 solution with notes.
This one seemed quite simple with the great built in functions on ClosedRange
.
The shex.quote
would be the proper public API to use in Python 3.3, but pipes.quote
is the alternative in lower versions. pipes.quote
is not public API, though. Should something else be used?
Se...
A small little change for renaming systém
to loggedSystem
, which seems like a more descriptive function name and is easier to type.